2
《华为技术认证 HCNA 网络技术实验指南》参考配置Ⅰ
发布于: 2021 年 02 月 27 日
最终配置参考
第一章 eNSP 及 VRP 基础操作
1.2 熟悉 VRP 基本操作
最终配置
<R1>display current-configuration
[V200R003C00]
#
sysname R1
header shell information "Welcome to Huawei certification lab"
header login information "hello"
#
clock timezone BJ add 08:00:00
clock daylight-saving-time Day Light Saving Time repeating 12:32 9-1 12:32 11-23 00:00 2005 2005
#
interface GigabitEthernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
Return
复制代码
1.3 熟悉常用的 IP 相关命令
最终配置
<R1>display current-configuration
[V200R003C00]
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 10.0.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.2.254 255.255.255.0
#
return
复制代码
1.4 配置通过 Telnet 登录系统
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 10.1.1.254 255.255.255.0
#
Return
<R2>display current-configuration
#
sysname R2
#
interface Ethernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
return
<R3>display current-configuration
#
sysname R3
#
interface Ethernet0/0/0
ip address 10.1.1.2 255.255.255.0
#
return
复制代码
1.5 配置通过 STelnet 登录系统
最终配置
<R1>display current-configuration
sysname R1
#
set cpu-usage threshold 80 restore 75
#
rsa peer-public-key 10.1.1.254
public-key-code begin
3047
0240
B910F7D8 EF50B04E CCF8692A 4F1B3FB3 202C3E66 B6D2C7EB FDBF0909 ED160F5E
76B5D916 CBB29432 F9044E04 8434B0AB E8FAB968 1672958B F732F788 0DA94F85
0203
010001
public-key-code end
peer-public-key end
#
interface GigabitEthernet0/0/0
ip address 10.1.1.1 255.255.255.0
#
ssh client 10.1.1.254 assign rsa-key 10.1.1.254
ssh client first-time enable
<R2>display current-configuration
sysname R2
#
aaa
authentication-scheme default
authorization-scheme default
accounting-scheme default
domain default
domain default_admin
local-user admin password cipher %$%$K8m.Nt84DZ}e#<0-8bmE3Uw}%$%$
local-user admin service-type http
local-user huawei1 password cipher %$%$cRb~BL,]5D(!v-QiMgd$:RxE%$%$
local-user huawei1 privilege level 3
local-user huawei1 service-type ssh
#
interface GigabitEthernet0/0/0
ip address 10.1.1.254 255.255.255.0
#
stelnet server enable
#
user-interface vty 0 4
auth
protocol inbound ssh
复制代码
1.6 配置通过 FTP 进行文件操作
最终配置
<R1>display current-configuration
[V200R003C00]
#
sysname R1
ftp server enable
#
aaa
local-user ftp password cipher %$%$%/xlTEcUeFU_="WB+iPI_n:M%$%$
local-user ftp ftp-directory flash:
local-user ftp service-type ftp
#
interface GigabitEthernet0/0/0
ip address 10.0.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.2.254 255.255.255.0
#
Return
复制代码
第二章 静态路由
2.1 静态路由及默认路由基本配置
最终配置
<R1>display current-configuration
#
sysname R1
#
interface Ethernet0/0/0
ip address 192.168.10.1 255.255.255.0
#
interface Serial0/0/0
link-protocol ppp
ip address 10.0.12.1 255.255.255.0
#
ip route-static 0.0.0.0 0.0.0.0 10.0.12.2
#
Return
<R2>display current-configuration
#
sysname R2
#
interface Serial0/0/0
link-protocol ppp
ip address 10.0.23.2 255.255.255.0
#
interface Serial0/0/1
link-protocol ppp
ip address 10.0.12.2 255.255.255.0
#
ip route-static 192.168.10.0 255.255.255.0 Serial0/0/1
ip route-static 192.168.20.0 255.255.255.0 10.0.23.3
#
Return
<R3>display current-configuration
#
sysname R3
#
interface Ethernet0/0/0
ip address 192.168.20.3 255.255.255.0
#
interface Serial0/0/1
link-protocol ppp
ip address 10.0.23.3 255.255.255.0
#
ip route-static 0.0.0.0 0.0.0.0 Serial0/0/1
#
Return
复制代码
2.2 浮动静态路由及负载均衡
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 192.168.10.1 255.255.255.0
#
interface Serial1/0/0
link-protocol ppp
ip address 10.1.12.1 255.255.255.0
#
interface Serial1/0/1
link-protocol ppp
ip address 10.1.13.1 255.255.255.0
#
ip route-static 192.168.20.0 255.255.255.0 10.1.13.3
ip route-static 192.168.20.0 255.255.255.0 10.1.12.2
#
Return
<R2>display current-configuration
#
sysname R2
#
interface Serial1/0/0
link-protocol ppp
ip address 10.1.12.2 255.255.255.0
#
interface Serial1/0/1
link-protocol ppp
ip address 10.1.23.2 255.255.255.0
#
ip route-static 192.168.10.0 255.255.255.0 10.1.12.1
ip route-static 192.168.20.0 255.255.255.0 10.1.23.3
#
Return
<R3>display current-configuration
#
sysname R3
#
interface GigabitEthernet0/0/0
ip address 192.168.20.1 255.255.255.0
#
interface Serial1/0/0
link-protocol ppp
ip address 10.1.23.3 255.255.255.0
#
interface Serial1/0/1
link-protocol ppp
ip address 10.1.13.3 255.255.255.0
#
ip route-static 192.168.10.0 255.255.255.0 10.1.13.1
ip route-static 192.168.10.0 255.255.255.0 10.1.23.2
#
Return
复制代码
第三章 RIP
3.1 RIP 路由协议基本配置
最终配置
<R1>display current-configuration
#
sysname R1
#
interface Ethernet0/0/0
ip address 10.0.12.1 255.255.255.0
#
interface LoopBack0
ip address 10.0.1.1 255.255.255.0
#
rip 1
version 2
network 10.0.0.0
#
return
<R2>display current-configuration
#
sysname R2
#
interface Ethernet0/0/0
ip address 10.0.12.2 255.255.255.0
#
interface LoopBack0
ip address 10.0.2.2 255.255.255.0
#
rip 1
version 2
network 10.0.0.0
#
return
复制代码
3.2 配置 RIPv2 的认证
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 192.168.10.1 255.255.255.0
#
interface GigabitEthernet0/0/1
link-protocolppp
ip address 10.0.12.1 255.255.255.0
rip authentication-mode md5 nonstandard $GOOD_=eh*)f8\~B3e~&Z5%# 1
#
rip 1
version 2
network 192.168.10.0
network 10.0.0.0
#
return
<R2>display current-configuration
#
sysname R2
#
interface GigabitEthernet0/0/0
ip address 192.168.20.1 255.255.255.0
#
interface GigabitEthernet0/0/1
link-protocolppp
ip address 10.0.12.2 255.255.255.0
rip authentication-mode md5 nonstandard &-nhYkNR4BC,%TLlYj-OAF@#
#
rip 1
version 2
network 192.168.20.0
network 10.0.0.0
#
return
<R3>display current-configuration
#
sysname R3
#
Interface loopback0
ip address 192.168.10.10 255.255.255.0
#
Interface loopback1
ip address 192.168.20.20 255.255.255.0
#
interface GigabitEthernet0/0/1
link-protocolppp
ip address 10.0.12.1 255.255.255.0
rip authentication-mode md5 nonstandard $GOOD_=eh*)f8\~B3e~&Z5%# 1
#
rip 1
version 2
network 192.168.10.0
network 192.168.20.0
network 10.0.0.0
#
Return
复制代码
3.3 RIP 路由协议的汇总
最终配置
<R1>display current-configuration
#
sysname R1
#
interface Serial0/0/0
link-protocol ppp
ip address 192.168.12.1 255.255.255.0
#
rip 1
version 2
network 192.168.12.0
#
return
<R2>display current-configuration
#
sysname R2
#
interface Serial0/0/0
link-protocol ppp
ip address 192.168.23.2 255.255.255.0
#
interface Serial0/0/1
link-protocol ppp
ip address 192.168.12.2 255.255.255.0
#
rip 1
version 2
network 192.168.12.0
network 192.168.23.0
#
return
<R3>display current-configuration
#
sysname R3
#
interface Serial0/0/1
link-protocol ppp
ip address 192.168.23.3 255.255.255.0
rip summary-address 3.3.0.0 255.255.252.0
#
interface LoopBack0
ip address 3.3.0.3 255.255.255.0
#
interface LoopBack1
ip address 3.3.1.3 255.255.255.0
#
interface LoopBack2
ip address 3.3.2.3 255.255.255.0
#
interface LoopBack3
ip address 3.3.3.3 255.255.255.0
#
rip 1
undo summary
version 2
network 192.168.23.0
network 3.0.0.0
#
return
复制代码
3.4 配置 RIP 的版本兼容、定时器及协议优先级
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 10.0.12.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.10.1 255.255.255.0
#
rip 1
version 2
network 10.0.0.0
network 192.168.10.0
preference 90
timers rip 20 120 60
#
return
<R2>display current-configuration
#
sysname R2
#
interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.20.1 255.255.255.0
#
rip 1
version 2
network 10.0.0.0
network 192.168.20.0
#
return
复制代码
3.5 配置 RIP 抑制接口及单播更新
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/1
ip address 172.16.1.254 255.255.255.0
#
rip 1
peer 172.16.1.100
peer 172.16.1.200
network 172.16.0.0
silent-interface GigabitEthernet0/0/1
#
Return
<R2>display current-configuration
#
sysname R2
#
interface Ethernet1/0/1
ip address 172.16.1.100 255.255.255.0
#
interface Ethernet1/0/0
ip address 172.16.2.254 255.255.255.0
#
rip 1
peer 172.16.1.254
peer 172.16.1.200
network 172.16.0.0
silent-interface Ethernet1/0/0
silent-interface Ethernet1/0/1
#
Return
<R3>display current-configuration
#
sysname R3
#
interface Ethernet1/0/1
ip address 172.16.1.200 255.255.255.0
undo rip output
#
interface Ethernet1/0/0
ip address 192.168.1.254 255.255.255.0
#
rip 1
peer 172.16.1.254
network 172.16.0.0
network 192.168.1.0
#
return
复制代码
3.6 RIP 与不连续子网
最终配置
<R1>display current-configuration
#
interface Ethernet0/0/0
ip address 10.0.12.1 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
#
<R2> display current-configuration
#
sysname R2
#
interface Ethernet0/0/0
ip address 10.0.12.2 255.255.255.0
#
interface Serial0/0/0
link-protocol ppp
ip address 192.168.23.2 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 192.168.23.0
#
<R3>display current-configuration
#
sysname R3
#
interface Serial0/0/0
link-protocol ppp
ip address 192.168.23.3 255.255.255.0
#
interface Serial0/0/1
link-protocol ppp
ip address 192.168.34.3 255.255.255.0
#
rip 1
undo summary
version 2
network 192.168.23.0
network 192.168.34.0
#
<R4>display current-configuration
#
sysname R4
interface Ethernet0/0/0
ip address 10.0.45.4 255.255.255.0
interface Serial0/0/1
link-protocol ppp
ip address 192.168.34.4 255.255.255.0
#
rip 1
undo summary
version 2
network 192.168.34.0
network 10.0.0.0
<R5>display current-configuration
#
sysname R5
#
interface Ethernet0/0/0
ip address 10.0.45.5 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
#
复制代码
3.7 RIP 的水平分割及触发更新
最终配置
<R1>display current-configuration
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 172.16.1.1 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 172.16.2.1 255.255.255.0
undo rip split-horizon
#
rip 1
version 2
network 172.16.0.0
#
Return
<R2>display current-configuration
#
sysname R2
#
interface Ethernet1/0/0
ip address 192.168.2.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 172.16.2.2 255.255.255.0
rip poison-reverse
#
rip 1
version 2
network 192.168.2.0
network 172.16.0.0
#
Return
<R3>display current-configuration
#
sysname R3
#
interface Ethernet1/0/0
ip address 192.168.1.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 172.16.1.2 255.255.255.0
#
rip 1
version 2
network 172.16.0.0
network 192.168.1.0
#
return
复制代码
3.8 配置 RIP 路由附加度量值
最终配置
<r1>display current-configuration
#
interface GigabitEthernet0/0/0
ip address 20.1.1.1 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 20.2.2.1 255.255.255.0
rip metricin 2
#
interface GigabitEthernet0/0/2
ip address 10.1.1.254 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 20.0.0.0
#
Return
<r2>display current-configuration
sysname r2
#
interface GigabitEthernet0/0/0
ip address 20.1.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 30.1.1.2 255.255.255.0
rip metricout 3
#
rip 1
undo summary
version 2
network 20.0.0.0
network 30.0.0.0
<r3>display current-configuration
#
sysname r3
#
interface GigabitEthernet0/0/0
ip address 30.2.2.3 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 20.2.2.3 255.255.255.0
#
rip 1
undo summary
version 2
network 20.0.0.0
network 30.0.0.0
#
Return
<r4>display current-configuration
#
sysname r4
#
interface GigabitEthernet0/0/0
ip address 30.2.2.4 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 30.1.1.4 255.255.255.0
#
interface GigabitEthernet0/0/2
ip address 40.1.1.254 255.255.255.0
#
rip 1
undo summary
version 2
network 30.0.0.0
network 40.0.0.0
#
return
复制代码
3.9 RIP 的故障处理
最终配置
<R1>display current-configuration
[V200R003C00]
#
sysname R1
#
interface GigabitEthernet0/0/0
ip address 192.168.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.2.2 255.255.255.0
#
rip 1
version 2
network 192.168.1.0
network 192.168.2.0
#
Return
<R2>display current-configuration
[V200R003C00]
#
sysname R2
#
interface Ethernet1/0/0
ip address 172.16.1.254 255.255.255.0
#
interface GigabitEthernet0/0/0
ip address 192.168.1.1 255.255.255.0
#
rip 1
version 2
network 172.16.0.0
network 192.168.1.0
#
Return
<R3>display current-configuration
[V200R003C00]
#
sysname R3
#
interface Ethernet1/0/0
ip address 172.16.2.254 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.2.1 255.255.255.0
#
rip 1
version 2
network 172.16.0.0
network 192.168.2.0
#
return
复制代码
3.10 RIP 的路由引入
最终配置
<R1>display current-configuration
#
sysname R1
#
interface Ethernet0/0/1
ip address 30.1.1.1 255.255.255.0
#
interface Ethernet0/0/2
ip address 10.1.1.1 255.255.255.0
#
interface Ethernet0/0/3
ip address 10.1.2.1 255.255.255.0
#
rip 1
undo summary
version 2
network 30.0.0.0
network 10.0.0.0
import-route static
#
ip route-static 40.1.1.0 255.255.255.0 30.1.1.2
#
return
<R2>display current-configuration
#
sysname R2
#
interface Ethernet0/0/0
ip address 20.1.1.254 255.255.255.0
#
interface Ethernet0/0/2
ip address 10.1.1.2 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
import-route direct
#
return
<R3>display current-configuration
#
sysname R3
#
interface Ethernet0/0/0
ip address 20.1.2.254 255.255.255.0
#
interface Ethernet0/0/3
ip address 10.1.2.2 255.255.255.0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 20.0.0.0
#
return
<R4>display current-configuration
#
sysname R4
#
interface Ethernet0/0/1
ip address 30.1.1.2 255.255.255.0
#
interface Ethernet0/0/2
ip address 40.1.1.254 255.255.255.0
#
interface Ethernet0/0/3
#
ip route-static 0.0.0.0 0.0.0.0 30.1.1.1
#
Return
复制代码
划线
评论
复制
发布于: 2021 年 02 月 27 日阅读数: 30
版权声明: 本文为 InfoQ 作者【依旧廖凯】的原创文章。
原文链接:【http://xie.infoq.cn/article/527ea8edabd19affdcf9b7b26】。
本文遵守【CC BY-NC-SA】协议,转载请保留原文出处及本版权声明。
依旧廖凯
关注
还未添加个人签名 2021.02.27 加入
还未添加个人简介
评论